2020-10-20 01:55 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000731Monteverdi2[Orfeo Toolbox (OTB)] Generalpublic2013-09-19 10:10
Reportergrizonnetm 
Assigned Tosalbert 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Summary0000731: Re-execute the same instance of an application is dangerous
Descriptionstep to reproduce :

- Run extract ROI on only 4 channels of a MS WV2 image (8 bands)
- after the ingestion of the output, do not close the Extract ROI application tab and restart the Extract ROI on the 8 bands.

The application crashes (code dumped) with the above message (assert on the histogram size):

mvd2-catalogue: /home/grizonnetm/projets/otb/src/Monteverdi2/Code/Common/Core/mvdHistogramModel.h :310 : mvd::HistogramModel::MeasurementType mvd::HistogramModel::Quantile(unsigned int, double, mvd::Bound) const: l'assertion « band<m_Histograms->Size() » a échoué.
Abandon (core dumped)
TagsNo tags attached.
Attached Files

-Relationships
parent of 0000749closedmickael Output of the applications are detected as inconsistent 
+Relationships

-Notes

~0001842

salbert (developer)

Bug reproduced with monteverdi2-0.3.1 not directly but after manual editing of color-setup.

This bug might be due to the fact that output image of OTB-application overwrites input image of dataset and that ingesting dataset tests emptiness of dataset directory to choose between loading or importing. Thus, after second run of OTB-application, dataset is reloaded (instead of imported) using the 4-band histogram and not the 8-band histogram.

Maybe a flag in DatasetModel::BuildContext which forces import of dataset may solve the problem.

~0001844

salbert (developer)

- Added forced import flag when importing overwritten result of OTB application;
- Added confirm overwrite message-box when executing OTB application;
- Changed File/Open to File/Import (using forced import flag);
- Improved dataset consistency check by using file creation date of dataset and input image (upgrading XML descriptor file).

~0001898

salbert (developer)

Fixed before releasing v-0.4.
+Notes

-Issue History
Date Modified Username Field Change
2013-06-24 17:45 grizonnetm New Issue
2013-07-16 12:08 salbert Assigned To => salbert
2013-07-16 12:08 salbert Status new => assigned
2013-07-16 12:19 salbert Note Added: 0001842
2013-07-23 12:31 salbert Note Added: 0001844
2013-07-23 12:31 salbert Resolution open => fixed
2013-07-26 13:41 mickael Resolution fixed => open
2013-07-26 13:41 mickael Relationship added parent of 0000749
2013-07-26 13:48 grizonnetm Status assigned => resolved
2013-09-19 10:10 salbert Note Added: 0001898
2013-09-19 10:10 salbert Status resolved => closed
2013-09-19 10:10 salbert Resolution open => fixed
+Issue History