2020-08-14 07:42 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000070OTB-applicationsGeneralpublic2011-12-16 13:26
Reporterjulien 
Assigned Tojulien 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Summary0000070: Using OTB_USE_GL_ACCEL streches images in scroll widget
DescriptionSee attached snapshots for illustration.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000091

julien (administrator)

The square where the texture is drawn has a size depending on the input image geometry.

~0000096

christop (administrator)

No difference any more between scroll, zoom and full resolution windows. => seg fault when resizing zoom in viewer manager.

~0000097

julien (administrator)

The hDisplayed() and wDisplayed() methods were redefined too low in the class hierarchy. Therefore when using the otb::FixedSizeFullImageWidget alone, the default implementation was called, leading to the stretching phenomena.

This has been fixed in revision :
http://hg.orfeo-toolbox.org/OTB/rev/ae28398a39cb

~0000101

christop (administrator)

Still have some problem with the zoom window. It might not be related to this fix and had been there before, but as the solution rely in the hDisplayed() and wDisplayed() methods I suspect, I don't open a new bug.

Open the viewer manager
Open qb_RoadExtract.tif
Show
Resize the zoom window to be bigger that the full resolution either in x or y (or both).
Click on the scroll

=>

itk::ExceptionObject (0x3cf4da0)
Location: "typename otb::ImageViewerBase<TPixel, TLabel>::RegionType otb::ImageViewerBase<TPixel, TLabel>::ComputeConstrainedRegion(typename otb::ImageViewerScrollWidget<TPixel, TLabel>::ImageType::RegionType, typename otb::ImageViewerScrollWidget<TPixel, TLabel>::ImageType::RegionType) [with TPixel = double, TLabel = double]"
File: /home/christop/OTB/trunk/OTB/Code/Visu/otbImageViewerBase.txx
Line: 800
Description: itk::ERROR: ImageViewer(0x15532a0): Small region not inside big region !

This should not fail, and the zoom should display at least the part of the full resolution that is buffered (we won't try to handle a specific extra buffer for this).

~0000106

julien (administrator)

The problem seems to be related to the ComputeConstrainedRegion() method of otb::ImageViewerBase, not to the hDisplayed() or wDisplayed() methods. Did some experiment leading to a better solution, but it is still not perfect. I commited my changes in a branch so as to focus on the 2.8 release for now.

~0000141

christop (administrator)

Is the branch merged now that 2.8 is out?

~0000625

julien (administrator)

This bug seems really outdated and related to the deprecated visualization classes. Shall I close it ?

~0000639

christop (administrator)

is it still reproducible?

~0001162

julien (administrator)

Applications and old visualisation are both deprecated. I suggest we close this bug.
+Notes

-Issue History
Date Modified Username Field Change
2009-01-09 14:52 julien New Issue
2009-01-09 14:52 julien File Added: snapshot_WithGLAccel.png
2009-01-09 14:53 julien File Added: snapshot_WithoutGLAccel.png
2009-01-09 16:32 julien Note Added: 0000091
2009-01-09 16:32 julien Status new => resolved
2009-01-09 16:32 julien Resolution open => fixed
2009-01-09 16:32 julien Assigned To => julien
2009-01-12 04:30 christop Note Added: 0000096
2009-01-12 04:30 christop Status resolved => feedback
2009-01-12 04:30 christop Resolution fixed => reopened
2009-01-12 09:53 julien Note Added: 0000097
2009-01-12 09:53 julien Status feedback => resolved
2009-01-12 09:53 julien Resolution reopened => fixed
2009-01-13 02:57 christop Note Added: 0000101
2009-01-13 02:57 christop Status resolved => feedback
2009-01-13 02:57 christop Resolution fixed => reopened
2009-01-13 15:10 julien Note Added: 0000106
2009-02-06 04:14 christop Note Added: 0000141
2011-04-29 10:51 julien Note Added: 0000625
2011-04-29 10:51 julien Status feedback => assigned
2011-04-30 21:13 christop Note Added: 0000639
2011-12-16 13:26 julien Note Added: 0001162
2011-12-16 13:26 julien Status assigned => closed
2011-12-16 13:26 julien Resolution reopened => fixed
+Issue History