2021-09-24 02:02 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000572Orfeo Toolbox (OTB)Generalpublic2015-04-17 11:32
Reporterjguinet 
Assigned Togpasero 
PriorityurgentSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformAllOSAllOS VersionAll
Summary0000572: using Segmentation application with .kml vector output using input which is not in WGS84 causes error
DescriptionSegmentation application returns itk exception with input which is not in WGS84 with .kml vector output

itk exception
Spatial reference of input image and target layer do not match!
Steps To ReproduceotbApplicationLauncherCommandLine Segmentation ./bin/ -in input.tif -mode vector -mode.vector.out vector.kml
Additional Informationthe exception occurs in Initialize method of PersistentImageToOGRLayerFilter class

http://hg.orfeo-toolbox.org/OTB/rev/02370bf00233#l1.4

in fact KML layers are created as WGS84. image spatial reference compatibility is checked using OGRCreateCoordinateTransformation between the two OGRSpatialReferences.

Since PersistentImageToOGRLayerFilter check if layer spatial reference and image spatial reference are the same, it causes exception if image spatial reference is not WGS84


TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001538

julienm (developer)

TODO : enrich exception message with the two spatial reference systems

~0001539

julien (administrator)

Add both spatial references to the exception and close the bug.

~0001552

gpasero (administrator)

Fixed here : http://hg.orfeo-toolbox.org/OTB/rev/613f9cbaa5e7
+Notes

-Issue History
Date Modified Username Field Change
2012-07-17 15:18 jguinet New Issue
2012-09-18 10:41 julien Assigned To => Guillaume
2012-09-18 10:41 julien Priority normal => high
2012-09-18 10:41 julien Status new => assigned
2012-09-18 10:42 julien Assigned To Guillaume => gpasero
2012-09-28 10:30 julienm Note Added: 0001538
2012-09-28 10:31 julien Note Added: 0001539
2012-09-28 10:53 julienm Priority high => urgent
2012-09-28 19:48 gpasero Note Added: 0001552
2012-09-28 19:48 gpasero Status assigned => resolved
2012-09-28 19:48 gpasero Resolution open => fixed
2015-04-17 11:32 julien Status resolved => closed
+Issue History