2020-09-19 18:19 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000047OTB-applicationsGeneralpublic2009-01-14 16:41
Reporteringlada 
Assigned Tojulien 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0000047: FineRegistration resampled image before run is shifted
DescriptionBefore running the registration, the resampled image should be identical to the moving one. However, these to images are horizontally shifted, one with respect to the other.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000055

julien (administrator)

At first I did not notice but looking carefully there is a slight shift between the two images (not more than one or two pixels).

~0000056

julien (administrator)

The bug seems to be located in the visualisation classes. When writing the color composition to the disk, there is no offset.

~0000057

julien (administrator)

The offset came from additionnal channel extraction in the view to handle the color composition modes. There were not necessary, since we can use the channel indices instead. Removing the extractor fixed the problem.

More information on the fix:
http://hg.orfeo-toolbox.org/OTB-Applications/rev/6b9c26eaf4a2

~0000062

christop (administrator)

Does that mean that there is a bug in the channel extractor?

~0000113

julien (administrator)

fixed.
+Notes

-Issue History
Date Modified Username Field Change
2008-12-09 10:43 inglada New Issue
2008-12-18 09:41 julien Note Added: 0000055
2008-12-18 09:41 julien Status new => confirmed
2008-12-18 10:35 julien Note Added: 0000056
2008-12-18 11:45 julien Note Added: 0000057
2008-12-18 11:45 julien Status confirmed => resolved
2008-12-18 11:45 julien Resolution open => fixed
2008-12-18 11:45 julien Assigned To => julien
2008-12-19 02:28 christop Note Added: 0000062
2009-01-14 16:40 julien Note Added: 0000113
2009-01-14 16:40 julien Status resolved => closed
+Issue History