2021-12-04 07:41 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000380OTB-lib[Monteverdi] Generalpublic2011-09-29 09:39
Reporterjguinet 
Assigned Tochristop 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformanyOSOS Version
Summary0000380: wavelet reconstruction filter problem
DescriptionWhen using wavelet transform, there is a problem when applying successively decomposition and reconstruction filter :

http://dash.orfeo-toolbox.org/testSummary.php?project=3&name=msTvWaveletMultiScaleTransformSPLINE_BIORTHOGONAL_2_4&date=2011-07-04

It seems to be due to reconstruction filter.

Generated filters are correct, however convolution with filtered output introduce translation. image used for reconstruction seems to be wrong. This problem is highlighted using wavelet_test_input.tif
Steps To ReproduceUse the same scheme as :

http://dash.orfeo-toolbox.org/testSummary.php?project=3&name=msTvWaveletMultiScaleTransformSPLINE_BIORTHOGONAL_2_4&date=2011-07-04

with wavelet_test_input.tif
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000919

julien (administrator)

I think this issue does not belong to the Monteverdi project. Can you move it to the OTB project ?

~0000929

christop (administrator)

Fixed by:
http://hg.orfeo-toolbox.org/OTB/rev/3160bcd665af

One of the oldest bug, yoohoo!

~0001030

C Valladeau (developer)

Tests OK.
+Notes

-Issue History
Date Modified Username Field Change
2011-07-04 10:20 jguinet New Issue
2011-07-04 10:20 jguinet Status new => assigned
2011-07-04 10:20 jguinet Assigned To => jguinet
2011-07-04 10:20 jguinet File Added: wavelet_test_input.tif
2011-07-04 10:52 julien Note Added: 0000919
2011-07-04 10:59 C Valladeau Project Monteverdi => OTB-lib
2011-07-18 01:13 christop Assigned To jguinet => christop
2011-07-18 01:14 christop Note Added: 0000929
2011-07-18 01:14 christop Status assigned => resolved
2011-07-18 01:14 christop Resolution open => fixed
2011-09-29 09:39 C Valladeau Note Added: 0001030
2011-09-29 09:39 C Valladeau Status resolved => closed
+Issue History