2018-09-25 13:01 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001488Orfeo Toolbox (OTB)Generalpublic2018-01-12 10:29
Reporterpoughov 
Assigned Togpasero 
PriorityurgentSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformWindowsOSOS Version
Summary0001488: OTB apps sometime do not appear in the widget
DescriptionSometimes with the OTB windows binary package, the OTB apps do not show up (as if OTB_APPLICATION_PATH was empty). But this happens when launching with the monteverdi.bat wrapper. It happens randomly and might depend on where on the filesystem the OTB package is extracted. For example, on my machine:

- Extraction in C:\Users\poughov\Downloads\OTB-6.2.0-Win64
-> works

- Extraction in C:\Users\poughov\Downloads\Formation OTB La Réunion\OTB-6.2.0-Win64\OTB-6.2.0-Win64
-> does not work
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004499

gpasero (administrator)

Problem reproduced with an accent in the path to the applications :
* On windows, the encoding was Latin-1 : é -> E9
* In ITK, in the DynamicLoader, there is a conversion of the input path to wide character, but the input encoding is assumed to be UTF-8.

It is probably a problem similar to the image with chinese.

~0004501

gpasero (administrator)

Maybe the best solution would be to patch ITK. But for now, I did a minimal fix :
https://git.orfeo-toolbox.org/otb.git/commit/ed7cd44b3cc832291d3845b3e82e6c42e36cc368

TODO : check if the bug is still present on next Windows binaries.

There is probably a larger discussion to have on how special characters are handled.

~0004507

gpasero (administrator)

Problem solved in latest windows binaries.
+Notes

-Issue History
Date Modified Username Field Change
2017-12-06 12:54 poughov New Issue
2018-01-05 14:24 gpasero Priority normal => urgent
2018-01-10 11:35 gpasero Assigned To => gpasero
2018-01-10 11:35 gpasero Status new => assigned
2018-01-10 16:10 gpasero Note Added: 0004499
2018-01-11 15:57 gpasero Note Added: 0004501
2018-01-12 10:29 gpasero Status assigned => resolved
2018-01-12 10:29 gpasero Resolution open => fixed
2018-01-12 10:29 gpasero Note Added: 0004507
+Issue History