2020-10-20 01:31 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001430OTB-Packaging[Orfeo Toolbox (OTB)] Generalpublic2017-06-13 22:49
Reportersaultdon 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64-bitOSArch LinuxOS Version
Summary0001430: building 6.0.0 fails at otbSFSTextureExtraction.cxx.o
DescriptionGetting the build to around 64% and it fails with:

Scanning dependencies of target otbapp_SFSTextureExtraction
[ 64%] Building CXX object Modules/Applications/AppTextures/app/CMakeFiles/otbapp_SFSTextureExtraction.dir/otbSFSTextureExtraction.cxx.o
In file included from /tmp/makepkg/orfeo-toolbox/src/OTB-release-6.0/Modules/Feature/Textures/include/otbSFSTexturesImageFilter.h:24:0,
                 from /tmp/makepkg/orfeo-toolbox/src/OTB-release-6.0/Modules/Applications/AppTextures/app/otbSFSTextureExtraction.cxx:25:
/tmp/makepkg/orfeo-toolbox/src/OTB-release-6.0/Modules/Feature/Textures/include/otbSFSTexturesFunctor.h: In member function ‘unsigned int otb::Functor::SFSTexturesFunctor<TIter, TOutputValue>::GetNumberOfDirections()’:
/tmp/makepkg/orfeo-toolbox/src/OTB-release-6.0/Modules/Feature/Textures/include/otbSFSTexturesFunctor.h:102:69: error: expression cannot be used as a function
   unsigned int GetNumberOfDirections(){ return m_NumberOfDirections(); }
                                                                     ^
make[2]: *** [Modules/Applications/AppTextures/app/CMakeFiles/otbapp_SFSTextureExtraction.dir/build.make:63: Modules/Applications/AppTextures/app/CMakeFiles/otbapp_SFSTextureExtraction.dir/otbSFSTextureExtraction.cxx.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:14988: Modules/Applications/AppTextures/app/CMakeFiles/otbapp_SFSTextureExtraction.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
Steps To Reproducetry to compile with 'make'
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004207

grizonnetm (administrator)

Hi,

good catch, thanks a lot for the report.

I've pushed a fix in the branch release-6.0 (and backport to develop branch):

https://git.orfeo-toolbox.org/otb.git/commit/4faf4e08573266c01b9d315414aa4af02a7893f6

If you compile from source and clone otb from git you can get the patch with:

git checkout release-6.0
git pull origin release-6.0

Let me know if it fix the issue on your side (I cannot reproduce the issue with my compiler).

Just for my personal knowledge, which compiler and version are you using?

Thanks again for your support.

Best,

~0004210

saultdon (reporter)

Thanks for the quick fix!

I have the following:
cmake 3.8.2
make 4.2.1
gcc 7.1.1
+Notes

-Issue History
Date Modified Username Field Change
2017-06-12 19:55 saultdon New Issue
2017-06-13 08:42 grizonnetm Note Added: 0004207
2017-06-13 08:43 grizonnetm Status new => resolved
2017-06-13 22:49 saultdon Note Added: 0004210
2017-06-13 22:49 saultdon Status resolved => closed
2017-06-13 22:49 saultdon Resolution open => fixed
+Issue History