2018-03-20 22:03 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001404OTB-Packaging[Orfeo Toolbox (OTB)] Generalpublic2018-01-09 17:35
Assigned Torashadkm 
PlatformLinuxOSOS VersionUbuntu 16.04
Summary0001404: OTB xdk 5.10.1 is not able to compile a simple program on a Ubuntu 16.04 VM
DescriptionThe bug appears on Ubuntu 16.04 installed in a virtual machine with VirtualBox:

The output of the linker error is provided in the file attached to the bug description.

There are at least 2 problems:

- missing libraries which does not seem to be part of the xdk archive:

/usr/bin/ld: warning: libexpat.so, needed by /home/otb/OTB-5.10.1-xdk-Linux64/lib/libgdal.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libfreetype.so, needed by /home/otb/OTB-5.10.1-xdk-Linux64/lib/libossim.so, not found (try using -rpath or -rpath-link)

Note that I've tested that installing freetype and expat withg apt fixes those specific link errors

- undefined references to ITK methods:

Pipeline.cxx:(.text._ZN3itk21MemoryAllocationErrorC2ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEjS8_S8_[_ZN3itk21MemoryAllocationErrorC5ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEjS8_S8_]+0x35) : référence indéfinie vers « itk::ExceptionObject::ExceptionObject(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, unsigned int, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char,

I was not able to fix those errors, I think that it could be related with libraries issues between the machine which build the xdk and the target platform (binutils, gcc, libc...I don't know)

Steps To ReproduceThe cmake project which triggers the error is available here:


The 5.10.1 xdk for Linnux is available here:


Note that exercice 1 also available in the same directory in otb-documents compiled and linked without issues
TagsNo tags attached.
Attached Files




rashadkm (developer)

which compiler gcc or clang?

and which version?


rashadkm (developer)

can you test the attached patch for xdk?

./OTB-5.10.1-xdk-Linux64-patch.run --target /path/to/existing/5.10.1-xdk-Linux64


grizonnetm (administrator)

the gcc version is 5.4.0

I'll not be able to test some patches, I do not have an up and running VM, I've seen this bug on someone else computer during an OTB training courses this week.


rashadkm (developer)

hmm. it seems like bug comes from freetype and expat.
a fix is hard if i cannot reproduce or test a patch.

anyway, using expat and freetype from package is the only good solution for long term.

earlier we only need to take care of gcc version as a dependency. Now it is spread over expat and freetype. This is bad and result in bugs such as above.

IIRC, the point of excluding freetype, expat are a workaround on qt lib issue. We should take out workaround and fix issue.

Anything I propose will take more time in fixing these new issues in packaging.

If interested let me know


rashadkm (developer)

a test called tu_build_examples is added in packaging to find this bug

-Issue History
Date Modified Username Field Change
2017-05-19 09:15 grizonnetm New Issue
2017-05-19 09:15 grizonnetm File Added: bug_otb_pipeline_vm_ubuntu1604.log
2017-05-19 09:22 rashadkm Note Added: 0004167
2017-05-19 10:43 rashadkm Assigned To => rashadkm
2017-05-19 10:43 rashadkm Status new => assigned
2017-05-19 10:45 rashadkm Note Added: 0004168
2017-05-19 11:02 grizonnetm Note Added: 0004169
2017-05-19 11:55 rashadkm Note Added: 0004170
2017-08-24 12:55 rashadkm Note Added: 0004260
2017-08-24 12:55 rashadkm Status assigned => resolved
2017-08-24 12:55 rashadkm Resolution open => fixed
2018-01-09 17:35 grizonnetm Status resolved => closed
+Issue History