2017-12-18 23:13 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001398Orfeo Toolbox (OTB)Generalpublic2017-07-12 09:44
Reportercybernar 
Assigned Tombertolino 
PriorityurgentSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS Version7
Summary0001398: OTB won't parse *.xml metadata file on newest Pleiades data
DescriptionI was unable to apply TOA reflectance calibration on 2017 Pleiades data.

So I checked the metadata with ReadImageInfo :

otbcli_ReadImageInfo -in "Input\IMG_PHR1B_MS_201703141059586_SEN_2270315101-002_R1C1.TIF" -keywordlist 1

OTB does not find "sensor :" information in metadata in my newest data; all the information about "support_data.*" keywords have disappeared too.
Steps To Reproduceotbcli_ReadImageInfo -in "Input\IMG_PHR1B_MS_201703141059586_SEN_2270315101-002_R1C1.TIF" -keywordlist 1

--> no information about "sensor :"
Additional Informationhttps://groups.google.com/d/msg/otb-users/sKqCjszf2GA/VSJpcqFIBAAJ

"For some reason OSSIM does not parse the DIMAP XML file correctly. "

XML files in the attached zip.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004162

julien (administrator)

After a closer look at the data, the problem comes from this check which is too restrictive :

https://git.orfeo-toolbox.org/otb.git/blob/refs/heads/release-6.0:/Modules/ThirdParty/OssimPlugins/src/ossim/ossimPleiadesDimapSupportData.cpp#l2030

we check that version == "2.0" and version is now 2.15 ... This is therefore easy to fix.

We also need to fix spot6 file, since it is likely that version changed too :

https://git.orfeo-toolbox.org/otb.git/blob/refs/heads/release-6.0:/Modules/ThirdParty/OssimPlugins/src/ossim/ossimSpot6DimapSupportData.cpp#l1672

~0004163

mbertolino (developer)

Fixed dimap version tests in ossim (Pleiades and Spot6).

fix here:
https://git.orfeo-toolbox.org/otb.git/commit/4b74d3a8e91bc462ca1cf2c2ef7624efc8f349b3

waiting for dashboard to close this issue.
+Notes

-Issue History
Date Modified Username Field Change
2017-05-05 13:16 cybernar New Issue
2017-05-05 13:16 cybernar File Added: IMG_PHR1B_MS_002.zip
2017-05-05 14:12 poughov Priority normal => urgent
2017-05-05 14:22 julien Note Added: 0004162
2017-05-05 15:47 mbertolino Assigned To => mbertolino
2017-05-05 15:47 mbertolino Status new => assigned
2017-05-09 11:51 mbertolino Note Added: 0004163
2017-05-09 11:51 mbertolino Status assigned => resolved
2017-07-12 09:44 grizonnetm Status resolved => closed
2017-07-12 09:44 grizonnetm Resolution open => fixed
+Issue History