2017-12-18 23:12 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001385Monteverdi2[Orfeo Toolbox (OTB)] Generalpublic2017-04-27 15:32
Reportersalbert 
Assigned ToLudovic 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionopen 
Summary0001385: Incorrect zoom level after manual zoom input
Description0- Open Monteverdi in Fullscreen (Maximized)
1- Open $/OTB-LargeInput/PLEIADES/TLSE_JP2_DIMAPv2_PRIMARY_PMS_lossless_12bits/IMGPHR_201222215194743808/IMG_PHR1A_PMS_201201151100183_SEN_IPU_20120222_0901-001_R1C1.JP2 (bottom)
2- Open $/OTB-LargeInput/QUICKBIRD/TOULOUSE/000000128955_01_P001_MUL/02APR01105228-M1BS-000000128955_01_P001.TIF (middle)
3- $/OTB-Data/Input/QB_Toulouse_Ortho_PAN.tif (top)
4- Set QUICKBIRD invisible
5- Select PLEAIDES
6- Change projection to Sensor-model of PLEIADES
6- Click zoom 1:1
7- Manually input zoom level '1:2' in the status-bar
=> Zoom changes and value '1.2' is displayed
8- Select another window on the user desktop (without any
=> Zoom level changes and value '1.38889:1' is displayed
(May be due to the fact that, when switching to another and overlapping window, the window manager sends a refresh signal to the image-view which renders another frame)
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004121

Ludovic (developer)

Point n°8 is corrected, commit: https://git.orfeo-toolbox.org/otb.git/commit/3b3d7b42d3fa195786de6bf4b35c03d6acbaaae5

A JIRA story (OTB-1255) has been created to discuss about the behavior/design of monteverdi with different images and projections.

~0004149

Ludovic (developer)

The zoom level line edit is now next to the Projection comboBox.

Bugfix for the point n°7 :
https://git.orfeo-toolbox.org/otb.git/commit/339884336ce296c9515e24d629cbe641bca8dbe7
+Notes

-Issue History
Date Modified Username Field Change
2017-04-10 15:41 salbert New Issue
2017-04-11 12:57 Ludovic Assigned To => Ludovic
2017-04-11 12:57 Ludovic Status new => assigned
2017-04-12 15:26 Ludovic Note Added: 0004121
2017-04-27 14:55 Ludovic Note Added: 0004149
2017-04-27 14:55 Ludovic Status assigned => resolved
2017-04-27 15:32 julien Status resolved => closed
+Issue History