2017-12-18 23:15 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001367Orfeo Toolbox (OTB)Generalpublic2017-04-05 10:22
Reportercarlo 
Assigned Togpasero 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformMacbookOSOSXOS Version10.11.6
Summary0001367: Monteverdi from the OTB standalone package for Mac OS X fails to run
DescriptionThe precompiled Monteverdi and Mapla applications contained in the self extracting archive for Mac OS X don't work on my macbook.

I tried with versions OTB-5.8.0-Darwin64.run and OTB-5.10.0-Darwin64.run.

When uncompressing the archive this messages show up on stdout/stderr:

Creating directory OTB-5.8.0-Darwin64
Verifying archive integrity... All good.
Uncompressing OrfeoToolBox 5.8.0 100%
Configuring...
sed: can't read s,STARTUP_FILE,Mapla,g: No such file or directory
sed: can't read s,LONG_VERSION,..,g: No such file or directory
sed: can't read s,SHORT_VERSION,.,g: No such file or directory
sed: can't read s,STARTUP_FILE,Monteverdi,g: No such file or directory
sed: can't read s,LONG_VERSION,..,g: No such file or directory
sed: can't read s,SHORT_VERSION,.,g: No such file or directory


Then when trying to run Monteverdi the following message pops up in Finder:

You can’t open the application “Monteverdi” because it may be damaged or incomplete.

When trying to run it from the terminal, it prints this then hangs for ever:

WARNG> Codec for C-strings: "none"
WARNG> Codec for Locale: "System"
WARNG> Codec for Tr: "UTF-8"
WARNG> Language: "English"
WARNG> Country: "UnitedStates"
WARNG> Runtime version of OpenGL used by Qt 4.8.7: 1.0.
WARNG> Version(s) of OpenGL supported by Qt 4.8.7:
WARNG> - QGLFormat::OpenGL_Version_2_1
WARNG> - QGLFormat::OpenGL_Version_2_0
WARNG> - QGLFormat::OpenGL_Version_1_5
WARNG> - QGLFormat::OpenGL_Version_1_4
WARNG> - QGLFormat::OpenGL_Version_1_3
WARNG> - QGLFormat::OpenGL_Version_1_2
WARNG> - QGLFormat::OpenGL_Version_1_1
WARNG> Runtime version of OpenGL used by Qt 4.8.7: 1.0.
WARNG> Version(s) of OpenGL supported by Qt 4.8.7:
WARNG> - QGLFormat::OpenGL_Version_2_1
WARNG> - QGLFormat::OpenGL_Version_2_0
WARNG> - QGLFormat::OpenGL_Version_1_5
WARNG> - QGLFormat::OpenGL_Version_1_4
WARNG> - QGLFormat::OpenGL_Version_1_3
WARNG> - QGLFormat::OpenGL_Version_1_2
WARNG> - QGLFormat::OpenGL_Version_1_1
WARNG> Failed to restore window layout!
WARNG> Required OpenGL version '2.0.0' with GLSL version '1.20'.
WARNG> Runtime OpenGL version '2.1 INTEL-10.14.73' with GLSL version '1.20'.




TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004059

gpasero (administrator)

In the deployment script there is a call to sed, for instance :

  sed -i "" "s,STARTUP_FILE,Mapla,g" "Mapla.app/Contents/Info.plist"

It seems that on your system you have a sed syntax that is different from the expected one.

For instance, on the MacOS X used to build the packages, the man page gives :
  sed [-Ealn] [-e command] [-f command_file] [-i extension] [file ...]

whereas on linux, the in-place option is : -i[SUFFIX], --in-place[=SUFFIX]

~0004060

gpasero (administrator)

Could you try to install the package using the native "BSD" sed. Maybe you have a different sed somewhere else on your system.

~0004062

carlo (reporter)

Indeed GNU sed was used. With the native BSD sed it works as expected. The issue is solved. Thank you!
+Notes

-Issue History
Date Modified Username Field Change
2017-02-28 19:38 carlo New Issue
2017-02-28 19:38 carlo File Added: Screen Shot 2017-02-28 at 19.37.49.png
2017-03-02 18:54 gpasero Note Added: 0004059
2017-03-02 18:54 gpasero Assigned To => gpasero
2017-03-02 18:54 gpasero Status new => acknowledged
2017-03-02 18:58 gpasero Note Added: 0004060
2017-03-02 18:58 gpasero Status acknowledged => feedback
2017-03-02 19:11 carlo Note Added: 0004062
2017-03-02 19:11 carlo Status feedback => assigned
2017-03-03 09:28 gpasero Status assigned => resolved
2017-03-03 09:28 gpasero Resolution open => fixed
2017-04-05 10:22 poughov Status resolved => closed
+Issue History