2017-12-18 23:00 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001366Orfeo Toolbox (OTB)Generalpublic2017-04-05 10:27
ReporterArthurV 
Assigned Tojulien 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0001366: OTB 5.10 : can't use extract ROI using bindings python
DescriptionCan't link together two Extract ROI without writing temporary data on disk or into RAM using python's bindings.
Steps To Reproduceto repeat bug, use the script attached :

python extract_ROI.py Stack_2x2Pix.tif output.tif bug

using RAM to stored temporary datas

python extract_ROI.py Stack_2x2Pix.tif output.tif
Additional Informationthe output error is :
itk::ERROR: ListViewParameter(0x19241d0): Value Channel1 not found in the list of choices: .

but, i think i've placed UpdateParameters() at the right place.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004048

julien (administrator)

This is because calling Execute() on an application wires the pipeline but does not call UpdateOutputInformation() on each image output. An easy fix would be to make sure it does.

~0004049

julien (administrator)

I pushed a fix here : https://git.orfeo-toolbox.org/otb.git/commitdiff/b49835d5e9a4f9967a86ca5b031c486d83d0c621

I registed the patch for dasbhoard testing. If it comes clean we can merge and close the bug.

~0004056

julien (administrator)

Fix merged.
+Notes

-Issue History
Date Modified Username Field Change
2017-02-28 10:35 ArthurV New Issue
2017-02-28 10:35 ArthurV File Added: extract_ROI.py
2017-02-28 10:52 julien Note Added: 0004048
2017-02-28 12:01 julien Note Added: 0004049
2017-02-28 12:01 julien Assigned To => julien
2017-02-28 12:01 julien Status new => confirmed
2017-03-02 15:48 julien Note Added: 0004056
2017-03-02 15:48 julien Status confirmed => resolved
2017-03-02 15:48 julien Resolution open => fixed
2017-04-05 10:27 poughov Status resolved => closed
+Issue History