MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001357Orfeo Toolbox (OTB)Generalpublic2017-02-08 12:022017-04-05 10:37
Reporterpoughov 
Assigned Togpasero 
PriorityurgentSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSCentOSOS Version7
Summary0001357: segfault when loading OTB applications in linux standalone package
Descriptionsegfault when loading OTB applications in standalone package. On Linux CentOS 7.
Additional InformationStarting program: /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/./bin/monteverdi
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Missing separate debuginfo for /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libpng12.so.0
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/3f/931fb517ec29f60f3ef1d31afdb0242a4beeaf.debug
Missing separate debuginfo for /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libz.so.1
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/7e/e9bc42787a0f9a793bdbfcb0671fd12c52bc2a.debug
Missing separate debuginfo for /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libfreetype.so.6
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/04/b814454060ccb3c3975940be1217de8f22dba2.debug
Missing separate debuginfo for /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libfontconfig.so.1
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/5c/ef2f0e7239d3d7c0ffaafe1dc72773406782a0.debug
Missing separate debuginfo for /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libexpat.so.1
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/e0/7f6437cada875d2782c71d138f246860cdc6ca.debug
Unable to load library icui18n "Cannot load library icui18n: (icui18n: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type)"
WARNG> Failed to load 'qt_fr_FR.qm' translation file from '/home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/qt4/translations'.
WARNG> Version OpenGL nécessaire '2.0.0' avec GLSL version '1.20'.
WARNG> Version OpenGL '3.0 Mesa 11.2.2' détectée avec GLSL version '1.30'.

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4e58be0 in otb::Wrapper::Application::GetLogger() ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBApplicationEngine-5.10.so.1
Missing separate debuginfos, use: debuginfo-install GConf2-3.2.6-8.el7.x86_64 OpenEXR-libs-1.7.1-7.el7.x86_64 PackageKit-gtk3-module-1.0.7-6.el7.centos.x86_64 adwaita-gtk2-theme-3.14.2.2-2.el7.x86_64 atk-2.14.0-1.el7.x86_64 bzip2-libs-1.0.6-13.el7.x86_64 cairo-1.14.2-1.el7.x86_64 dbus-glib-0.100-7.el7.x86_64 dbus-libs-1.6.12-17.el7.x86_64 elfutils-libelf-0.166-2.el7.x86_64 elfutils-libs-0.166-2.el7.x86_64 gamin-0.1.10-16.el7.x86_64 gdk-pixbuf2-2.31.6-3.el7.x86_64 glib2-2.46.2-4.el7.x86_64 glibc-2.17-157.el7_3.1.x86_64 graphite2-1.3.6-1.el7_2.x86_64 gtk2-2.24.28-8.el7.x86_64 harfbuzz-0.9.36-1.el7.x86_64 ilmbase-1.0.3-7.el7.x86_64 jasper-libs-1.900.1-29.el7.x86_64 kdelibs-4.14.8-5.el7_2.x86_64 keyutils-libs-1.5.8-3.el7.x86_64 krb5-libs-1.14.1-27.el7_3.x86_64 libICE-1.0.9-2.el7.x86_64 libSM-1.2.2-2.el7.x86_64 libX11-1.6.3-3.el7.x86_64 libXau-1.0.8-2.1.el7.x86_64 libXcomposite-0.4.4-4.1.el7.x86_64 libXcursor-1.1.14-2.1.el7.x86_64 libXdamage-1.1.4-4.1.el7.x86_64 libXext-1.3.3-3.el7.x86_64 libXfixes-5.0.1-2.1.el7.x86_64 libXi-devel-1.7.4-2.el7.x86_64 libXinerama-1.1.3-2.1.el7.x86_64 libXrandr-1.4.2-2.el7.x86_64 libXrender-0.9.8-2.1.el7.x86_64 libXxf86vm-1.1.3-2.1.el7.x86_64 libattr-2.4.46-12.el7.x86_64 libcanberra-0.30-5.el7.x86_64 libcanberra-gtk2-0.30-5.el7.x86_64 libcap-2.22-8.el7.x86_64 libcom_err-1.42.9-9.el7.x86_64 libdrm-2.4.67-3.el7.x86_64 libffi-3.0.13-18.el7.x86_64 libgcc-4.8.5-11.el7.x86_64 libgomp-4.8.5-11.el7.x86_64 libidn-1.28-4.el7.x86_64 libogg-1.3.0-7.el7.x86_64 libpciaccess-0.13.4-2.el7.x86_64 libpng-1.5.13-7.el7_2.x86_64 libselinux-2.5-6.el7.x86_64 libstdc++-4.8.5-11.el7.x86_64 libtdb-1.3.8-1.el7_2.x86_64 libtool-ltdl-2.4.2-21.el7_2.x86_64 libuuid-2.23.2-33.el7.x86_64 libvorbis-1.3.3-8.el7.x86_64 libxcb-1.11-4.el7.x86_64 libxshmfence-1.2-1.el7.x86_64 mesa-dri-drivers-11.2.2-2.20160614.el7.x86_64 mesa-libEGL-11.2.2-2.20160614.el7.x86_64 mesa-libGL-11.2.2-2.20160614.el7.x86_64 mesa-libGLU-9.0.0-4.el7.x86_64 mesa-libgbm-11.2.2-2.20160614.el7.x86_64 mesa-libglapi-11.2.2-2.20160614.el7.x86_64 nss-softokn-freebl-3.16.2.3-14.4.el7.x86_64 openssl-libs-1.0.1e-60.el7.x86_64 pango-1.36.8-2.el7.x86_64 pcre-8.32-15.el7_2.1.x86_64 pixman-0.34.0-1.el7.x86_64 qt-4.8.5-13.el7.x86_64 systemd-libs-219-30.el7_3.6.x86_64 xz-libs-5.2.2-1.el7.x86_64
(gdb) bt
#0 0x00007ffff4e58be0 in otb::Wrapper::Application::GetLogger() ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBApplicationEngine-5.10.so.1
#1 0x00007ffff4e6e186 in otb::Wrapper::CompositeApplication::AddApplication(std::string, std::string, std::string) ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBApplicationEngine-5.10.so.1
#2 0x00007fffc625ac3f in otb::Wrapper::TrainImagesClassifier::DoInit() ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/otb/applications/otbapp_TrainImagesClassifier.so
#3 0x00007ffff4e58d77 in otb::Wrapper::Application::Init() () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBApplicationEngine-5.10.so.1
#4 0x00007ffff4e6999a in otb::Wrapper::ApplicationRegistry::LoadApplicationFromPath(std::string, std::string) ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBApplicationEngine-5.10.so.1
0000005 0x00007ffff4e6b237 in otb::Wrapper::ApplicationRegistry::GetAvailableApplications(bool) ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBApplicationEngine-5.10.so.1
#6 0x00007ffff78c6e72 in mvd::ApplicationsBrowser::GetAvailableApplications() ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBMonteverdiCore-5.10.so.1
#7 0x00007ffff78c75e8 in mvd::ApplicationsBrowser::SearchAvailableApplicationsTags() ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBMonteverdiCore-5.10.so.1
#8 0x00007ffff7b4b252 in mvd::AbstractModelController::SetModel(mvd::AbstractModel*) ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libOTBMonteverdiGUI-5.10.so.1
#9 0x000000000040f02f in mvd::MainWindow::SetupOTBApplications() ()
0000010 0x000000000041e1b1 in mvd::MainWindow::qt_metacall(QMetaObject::Call, int, void**) ()
0000011 0x00007ffff655dd18 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtCore.so.4
0000012 0x00007ffff6acf612 in QAction::triggered(bool) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000013 0x00007ffff6ad0bf7 in QAction::activate(QAction::ActionEvent) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000014 0x00007ffff6eec6a9 in ?? () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000015 0x00007ffff6ef0699 in ?? () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000016 0x00007ffff6b246a6 in QWidget::event(QEvent*) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000017 0x00007ffff6ef44ab in QMenu::event(QEvent*) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000018 0x00007ffff6ad52ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
#19 0x00007ffff6adb986 in QApplication::notify(QObject*, QEvent*) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000020 0x00007ffff654a39d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtCore.so.4
0000021 0x00007ffff6adb113 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000022 0x00007ffff6b4c89c in ?? () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000023 0x00007ffff6b4afdc in QApplication::x11ProcessEvent(_XEvent*) () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000024 0x00007ffff6b719e2 in ?? () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
0000025 0x00007ffff0dc7d7a in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
0000026 0x00007ffff0dc80b8 in g_main_context_iterate.isra.24 () from /lib64/libglib-2.0.so.0
0000027 0x00007ffff0dc816c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
0000028 0x00007ffff6575e85 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtCore.so.4
0000029 0x00007ffff6b71a96 in ?? () from /home/poughov/Téléchargements/testlibgtk/OTB-5.10.0-Linux64/lib/libQtGui.so.4
---Type <return> to continue, or q <return> to quit---q
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004021)
poughov (administrator)
2017-02-09 09:21

Still crashing with today's package, after: Revert "BUG: prevent tinyxml header to define DEBUG on windows, conflict with itk::LoggerBase::DEBUG"
(0004022)
Ludovic (developer)
2017-02-09 09:44

Probably my bad with a patch applied for debian distribution...
I don't know why i pushed it but it's now revert.
(0004025)
grizonnetm (administrator)
2017-02-09 10:01

Note that I don't reproduce the crash on Ubuntu 16.04
(0004026)
gpasero (administrator)
2017-02-09 10:19

Reproduced on today's package on my Ubuntu 14.04

Last working package was 2017-02-06
(0004027)
gpasero (administrator)
2017-02-09 15:13

It is (yet an other) packaging issue. The commit introducing this bug is :
https://git.orfeo-toolbox.org/otb.git/commit/290e1a084f958ee3b7548cb80ad1aab9b63c8e4a [^]

Prior to this commit, we were adding the latest libstdc++ from hulk in the package, but binaries are built with an older one (gcc4.8).
I need to check if all binaries are compiled with the same compiler version.
(0004028)
gpasero (administrator)
2017-02-09 18:47

Found something : the application TrainVectorClassifier can't be loaded. Hence TrainImagesClassifier can't be loaded either (because it uses it).

Here is some output from ldd on otbapp_TrainVectorClassifier :
lib/otb/applications/otbapp_TrainVectorClassifier.so: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/gpasero/Projet_OTB/release/5.10/OTB-contrib-5.10.0-Linux64/lib/libboost_serialization.so.1.60.0)

It seems that in the superbuild, Boost was not compiled using the right gcc version.

I will fix the environment on hulk : export CC, CXX, CPP, LD, setup aliases for gcc, g++, cc, ld, ...
(0004030)
gpasero (administrator)
2017-02-10 14:41

Problem solved, I found the right environment setup to build all the superbuild with gcc-4.8 :

* export variables :
  * CC = /usr/bin/gcc-4.8
  * CXX = /usr/bin/g++-4.8
  * CPP = /usr/bin/cpp-4.8

* create a dedicated folder 'my_gcc' with symlinks and place this folder in first position in $PATH :
  * c++ -> /usr/bin/g++-4.8
  * cc -> /usr/bin/gcc-4.8
  * cpp -> /usr/bin/cpp-4.8
  * g++ -> /usr/bin/g++-4.8
  * gcc -> /usr/bin/gcc-4.8

* in SuperBuild CMake cache : set the variables CMAKE_C_COMPILER and CMAKE_CXX_COMPILER to use resp. gcc-4.8 and g++-4.8

I tried to also set the linker to use gcc-4.8 but I didn't worked, CMake still wanted to use /usr/bin/ld (which points to ld.bfd).

- Issue History
Date Modified Username Field Change
2017-02-08 12:02 poughov New Issue
2017-02-09 09:21 poughov Note Added: 0004021
2017-02-09 09:44 Ludovic Note Added: 0004022
2017-02-09 10:01 grizonnetm Note Added: 0004025
2017-02-09 10:19 gpasero Note Added: 0004026
2017-02-09 10:33 gpasero Assigned To => gpasero
2017-02-09 10:33 gpasero Status new => assigned
2017-02-09 15:13 gpasero Note Added: 0004027
2017-02-09 18:47 gpasero Note Added: 0004028
2017-02-10 14:41 gpasero Note Added: 0004030
2017-02-10 14:41 gpasero Status assigned => resolved
2017-02-10 14:41 gpasero Resolution open => fixed
2017-04-05 10:37 poughov Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker