MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001334OTB-Packaging[Orfeo Toolbox (OTB)] Generalpublic2017-01-16 09:542017-04-27 15:32
Reporterjulien 
Assigned Togpasero 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSOS Version
Summary0001334: On Windows standalone package, selection and drag&drop is broken on Monteverdi layer stack
DescriptionOn Windows standalone package, selection and drag&drop is broken on Monteverdi layer stack.
Steps To ReproduceSelecting an item in layer stack with a single click does not work. One has to drag a little with mouse button pressed so as to get the item selected.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0001309closedrashadkm Monteverdi2 Monteverdi 5.8: cannot drag and drop filename to OTB app 

-  Notes
(0003964)
gpasero (administrator)
2017-01-26 18:41

I reproduced this bug on a SuperBuild, so it doesn't come from packaging side. I will investigate QT4 build options.
(0003980)
grizonnetm (administrator)
2017-01-31 11:06

Note that Monteverdi 5.8 crashes with windows standalone package when clicking on the same widget (listView?) in the overview generation window which list images on which you can generate .ovr.

Don't know if it is related but it concerns the same Qt widget.
(0003999)
gpasero (administrator)
2017-02-02 09:33

Yes, I also noticed. This is the same widget (QTreeView).

I could observe what is happening, but no fix for the moment :
* when clicking on the item in the ImportImageDialog (for ovr generation), the QItemSelectionModel::currentChanged() signal is emitted with the correct index selected
* just after, the currentChanged() signal is emitted again with an invalid index.
(0004014)
gpasero (administrator)
2017-02-07 15:52

Fix pushed here in release 5.10 : https://git.orfeo-toolbox.org/otb.git/commit/ef0be61fb38532906c3eafde553f6efde689c39c [^]

There was a bad QPoint initialization in QTreeView::setSelection(). MSVC15 in release mode wasn't handling well the multiple layers of "(a?b:c)" evaluations.
qMax() and qMin() are inline functions that also use (a?b:c) pattern.
(0004096)
poughov (administrator)
2017-04-05 10:40

TODO:
push fix to QT so that it's also fixed when not using SuperBuild.

- Issue History
Date Modified Username Field Change
2017-01-16 09:54 julien New Issue
2017-01-16 17:14 rashadkm Assigned To => rashadkm
2017-01-16 17:14 rashadkm Status new => acknowledged
2017-01-20 09:22 Ludovic Relationship added duplicate of 0001309
2017-01-26 18:41 gpasero Note Added: 0003964
2017-01-31 11:06 grizonnetm Note Added: 0003980
2017-01-31 11:07 grizonnetm Platform => Windows
2017-02-02 09:33 gpasero Note Added: 0003999
2017-02-02 09:33 gpasero Assigned To rashadkm => gpasero
2017-02-02 09:33 gpasero Status acknowledged => assigned
2017-02-07 15:52 gpasero Note Added: 0004014
2017-02-07 15:52 gpasero Status assigned => resolved
2017-02-07 15:52 gpasero Resolution open => fixed
2017-04-05 10:40 poughov Note Added: 0004096
2017-04-27 15:32 julien Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker