2019-11-12 22:46 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001247Orfeo Toolbox (OTB)Generalpublic2016-07-05 16:17
Reportersebastic 
Assigned Torashadkm 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0001247: Patch for various spelling errors
DescriptionThe spelling errors were reported by the lintian QA tool for the most recent Debian package build.

 * allows to <verb> -> allows <verb>ing
 * catched -> caught
 * ouptut -> output
 * symetric -> symmetric
TagsNo tags attached.
Attached Files
  • patch file icon spelling-errors.patch (8,965 bytes) 2016-07-04 21:39 -
    Description: Fix spelling errors.
     allows to <verb> -> allows <verb>ing
     catched          -> caught
     ouptut           -> output
     symetric         -> symmetric
    Author: Bas Couwenberg <sebastic@debian.org>
    
    --- a/Modules/Filtering/ImageManipulation/include/otbGridResampleImageFilter.txx
    +++ b/Modules/Filtering/ImageManipulation/include/otbGridResampleImageFilter.txx
    @@ -238,8 +238,8 @@ GridResampleImageFilter<TInputImage, TOu
         }
     
       // Compute ReachableOutputRegion
    -  // InputImage buffered region corresponds to a region of the ouptut
    -  // image. Computing it beforehand allows to save IsInsideBuffer
    +  // InputImage buffered region corresponds to a region of the output
    +  // image. Computing it beforehand allows saving IsInsideBuffer
       // calls in the interpolation loop
       
       // Compute the padding due to the interpolator
    --- a/Modules/Applications/AppClassification/app/otbDSFuzzyModelEstimation.cxx
    +++ b/Modules/Applications/AppClassification/app/otbDSFuzzyModelEstimation.cxx
    @@ -414,7 +414,7 @@ private:
           {
           // An error has occurred in the optimization.
           // Update the parameters
    -      otbAppLogFATAL("ERROR: Exception Catched : "<< err.GetDescription() << std::endl
    +      otbAppLogFATAL("ERROR: Exception Caught : "<< err.GetDescription() << std::endl
             << "numberOfIterations : " << m_Optimizer->GetOptimizer()->get_num_evaluations() << std::endl
             << "Results : " << m_Optimizer->GetCurrentPosition() << std::endl);
           }
    --- a/Modules/Applications/AppSARDecompositions/app/otbSARDecompositions.cxx
    +++ b/Modules/Applications/AppSARDecompositions/app/otbSARDecompositions.cxx
    @@ -134,7 +134,7 @@ private:
         SetParameterDescription("decomp.pauli","Pauli coherent decomposition");
         
         AddParameter(ParameterType_Group,"inco","Incoherent decompositions");
    -    SetParameterDescription("inco","This group allows to set parameters related to the incoherent decompositions.");
    +    SetParameterDescription("inco","This group allows setting parameters related to the incoherent decompositions.");
         
         AddParameter(ParameterType_Int, "inco.kernelsize",   "Kernel size for spatial incoherent averaging.");
         SetParameterDescription("inco.kernelsize", "Minute (0-59)");
    --- a/Modules/Visualization/Ice/include/otbGlView.h
    +++ b/Modules/Visualization/Ice/include/otbGlView.h
    @@ -104,7 +104,7 @@ public:
       void Initialize(unsigned int sx, unsigned int sy);
     
       /**
    -   * This method allows to add a new actor (deriving from GlActor) to
    +   * This method allows adding a new actor (deriving from GlActor) to
        * the GlView. The actor can be identified by an optional key. If
        * not provided, and the default value is used, the method will
        * generate a key to identify the actor. In both case, the key is
    @@ -132,7 +132,7 @@ public:
       void ClearActors();
     
       /**
    -   * This method allows to retrieve a pointer to the actor identified
    +   * This method allows retrieving a pointer to the actor identified
        * by the given key.
        * \param key The key identifying the actor to retrieve
        * \return A pointer to the retrieved actor. This pointer will be
    --- a/Modules/Applications/AppSARPolarMatrixConvert/app/otbSARPolarMatrixConvert.cxx
    +++ b/Modules/Applications/AppSARPolarMatrixConvert/app/otbSARPolarMatrixConvert.cxx
    @@ -193,7 +193,7 @@ private:
         "This application allows converting classical polarimetric matrices to each other.\n"
         "For instance, it is possible to get the coherency matrix from the Sinclar one, or the Mueller matrix from the coherency one.\n"
         "The filters used in this application never handle matrices, but images where each band is related to their elements.\n"
    -    "As most of the time SAR polarimetry handles symetric/hermitian matrices, only the relevant elements are stored, so that the images representing them have a minimal number of bands.\n"
    +    "As most of the time SAR polarimetry handles symmetric/hermitian matrices, only the relevant elements are stored, so that the images representing them have a minimal number of bands.\n"
         "For instance, the coherency matrix size is 3x3 in the monostatic case, and 4x4 in the bistatic case : it will thus be stored in a 6-band or a 10-band complex image (the diagonal and the upper elements of the matrix).\n"
         "\n"
         "The Sinclair matrix is a special case : it is always represented as 3 or 4 one-band complex images (for mono- or bistatic case).\n"
    --- a/Modules/Applications/AppSARPolarSynth/app/otbSARPolarSynth.cxx
    +++ b/Modules/Applications/AppSARPolarSynth/app/otbSARPolarSynth.cxx
    @@ -63,7 +63,7 @@ private:
     						  "\n"
     						  "In order to determine the architecture, the application first relies on the number of bands of the input image.\n" 
     						  "1) Architecture HH_HV_VH_VV is the only one with four bands, there is no possible confusion.\n"
    -						  "2) Concerning HH_HV_VV and HH_VH_VV architectures, both correspond to a three channels image. But they are processed in the same way, as the Sinclair matrix is symetric in the monostatic case.\n"
    +						  "2) Concerning HH_HV_VV and HH_VH_VV architectures, both correspond to a three channels image. But they are processed in the same way, as the Sinclair matrix is symmetric in the monostatic case.\n"
     						  "3) Finally, the two last architectures (dual polarizations), can't be distinguished only by the number of bands of the input image.\n"
     						  "   User must then use the parameters emissionh and emissionv to indicate the architecture of the system : emissionh=1 and emissionv=0 --> HH_HV,  emissionh=0 and emissionv=1 --> VH_VV.\n"
     						  "Note : if the architecture is HH_HV, khii and psii are automatically set to 0°/0°; if the architecture is VH_VV, khii and psii are automatically set to 0°/90°.\n"
    --- a/Modules/Core/LabelMap/include/otbShapeAttributesLabelMapFilter.txx
    +++ b/Modules/Core/LabelMap/include/otbShapeAttributesLabelMapFilter.txx
    @@ -380,7 +380,7 @@ ShapeAttributesLabelObjectFunctor<TLabel
           // do this one here to avoid the double assigment in the following loop
           // when i == j
           centralMoments[i][i] += length * physicalPosition[i] * physicalPosition[i];
    -      // central moments are symetrics, so avoid to compute them 2 times
    +      // central moments are symmetrics, so avoid to compute them 2 times
           for (DimensionType j = i + 1; j < LabelObjectType::ImageDimension; ++j)
             {
             // note that we won't use that code if the image dimension is less than 3
    --- a/Modules/Feature/Descriptors/include/otbImageToHessianDeterminantImageFilter.h
    +++ b/Modules/Feature/Descriptors/include/otbImageToHessianDeterminantImageFilter.h
    @@ -51,7 +51,7 @@ public:
     
       /*
        *
    -   * \param input : A symetric Hessian Matrix
    +   * \param input : A symmetric Hessian Matrix
        * \return  Determinant of the Hessian Matrix
        */
       inline TOutput operator ()(const TInput& input)
    --- a/Modules/Feature/Edge/include/otbAssociativeSymmetricalSumImageFilter.h
    +++ b/Modules/Feature/Edge/include/otbAssociativeSymmetricalSumImageFilter.h
    @@ -24,7 +24,7 @@ namespace otb
     {
     
     /** \class AssociativeSymmetricalSumImageFilter
    - * \brief Implements an assymetric fusion of line detector image filter.
    + * \brief Implements an asymmetric fusion of line detector image filter.
      *
      * This class implements a fusion of the output images of
      * otb::LineRatioDetector and otb::LineCorrelationDetector
    --- a/Modules/Registration/Stereo/include/otbLineOfSightOptimizer.h
    +++ b/Modules/Registration/Stereo/include/otbLineOfSightOptimizer.h
    @@ -66,7 +66,7 @@ public:
     
       /** Compute the best intersection between N lines of sight.
        *  Starting points of every line of sight are stored in the point set 'pointA'
    -   *  ending points are stored in 'pointB' (however, the computation is symetrical)*/
    +   *  ending points are stored in 'pointB' (however, the computation is symmetrical)*/
       PointType Compute(PointSetPointerType pointA, PointSetPointerType pointB);
     
       /** Get the residues from last computation */
    --- a/Modules/Segmentation/Labelling/include/otbLabelToBoundaryImageFilter.h
    +++ b/Modules/Segmentation/Labelling/include/otbLabelToBoundaryImageFilter.h
    @@ -30,7 +30,7 @@ namespace Functor
      * \brief Functor to extract segmentation boundaries
      * 
      * Functor intended to work with 3x3 neighborhood and scalar label image
    - * The generated boundary is 1-pixel wide, so it is not symetric. 
    + * The generated boundary is 1-pixel wide, so it is not symmetric. 
      * Output value is 1 on the boundaries and 0 in the background
      * 
      * \ingroup OTBLabelling
    @@ -63,7 +63,7 @@ public:
      * \brief Filter to extract boundaries of a label image
      * 
      * Filter intended to work with a scalar label image.
    - * The generated boundary is 1-pixel wide, so it is not symetric. 
    + * The generated boundary is 1-pixel wide, so it is not symmetric. 
      * Output value is 1 on the boundaries and 0 in the background
      * 
      * \ingroup OTBLabelling
    
    patch file icon spelling-errors.patch (8,965 bytes) 2016-07-04 21:39 +

-Relationships
+Relationships

+Notes

-Issue History
Date Modified Username Field Change
2016-07-04 21:39 sebastic New Issue
2016-07-04 21:39 sebastic File Added: spelling-errors.patch
2016-07-05 16:16 rashadkm Note Added: 0003557
2016-07-05 16:16 rashadkm Status new => resolved
2016-07-05 16:16 rashadkm Resolution open => fixed
2016-07-05 16:16 rashadkm Assigned To => rashadkm
2016-07-05 16:17 rashadkm Status resolved => closed
+Issue History