2022-01-27 12:11 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001231Monteverdi2[Orfeo Toolbox (OTB)] Generalpublic2017-03-21 16:17
Reporterpoughov 
Assigned ToLudovic 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS Version7
Summary0001231: Monteverdi: shader effect does not follow the mouse cursor when moving
DescriptionWhen moving the image view with a mouse drag, the shader effect does not follow the mouse cursor until the clicking button is released.
Steps To ReproduceUse the "spectral angle" effect and move the image.
TagsNo tags attached.
Attached Files

-Relationships
related to 0001197closedsalbert Clicking on minimap to navigate result in monteverdi crashing 
+Relationships

-Notes

~0003556

salbert (developer)

Issue is present since this commit: http://git.orfeo-toolbox.org/monteverdi2.git/commitdiff/d7922c94378615abedee760a1402721972cd159e because update of shader pixel-color and mouse-point parameters are done in imageViewRenderer::UpdatePixelInfo() [1] called from ImageViewWidget::mouseMoveEvent() [2].

I guess that this commit was done to save some CPU time when navigating the view.

[1] http://git.orfeo-toolbox.org/monteverdi2.git/blob/refs/heads/develop:/Code/Common/Gui/mvdImageViewRenderer.cxx#l1099
[2] http://git.orfeo-toolbox.org/monteverdi2.git/blob/refs/heads/develop:/Code/Common/Gui/mvdImageViewWidget.cxx#l744

~0003559

salbert (developer)

Fixed here: http://git.orfeo-toolbox.org/monteverdi2.git/shortlog/refs/heads/bugfix-1231

Also contains small optimization of rendering when mouse moving/dragging.

(Will be merged into release branches when version is bumped up)

~0004073

Ludovic (developer)

Last edited: 2017-03-21 11:27

View 2 revisions

The same problem is present on windows with OTB 5.10.1, shader effect is apply above the cursor mouse. Only Y coordinate is affected.

The distance between cursor and the center of the effect is reduced when the Main windows is also reduced.

Edit: Unlike the previous error the problem is still present even after a click

+Notes

-Issue History
Date Modified Username Field Change
2016-06-16 17:52 poughov New Issue
2016-07-01 12:17 salbert Assigned To => salbert
2016-07-01 12:17 salbert Status new => assigned
2016-07-04 17:12 salbert Relationship added related to 0001197
2016-07-04 17:52 salbert Note Added: 0003556
2016-07-06 17:25 salbert Note Added: 0003559
2016-07-06 17:25 salbert Status assigned => resolved
2016-07-06 17:25 salbert Resolution open => fixed
2017-03-21 11:23 Ludovic Assigned To salbert =>
2017-03-21 11:23 Ludovic Note Added: 0004073
2017-03-21 11:23 Ludovic Status resolved => feedback
2017-03-21 11:23 Ludovic Resolution fixed => reopened
2017-03-21 11:24 Ludovic Reproducibility have not tried => always
2017-03-21 11:24 Ludovic OS => Windows
2017-03-21 11:24 Ludovic OS Version => 7
2017-03-21 11:27 Ludovic Note Edited: 0004073 View Revisions
2017-03-21 11:31 Ludovic Assigned To => Ludovic
2017-03-21 11:31 Ludovic Status feedback => assigned
2017-03-21 16:17 Ludovic Status assigned => closed
2017-03-21 16:17 Ludovic Resolution reopened => fixed
+Issue History