2021-12-04 08:47 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001070Monteverdi2[Orfeo Toolbox (OTB)] Generalpublic2015-11-10 10:09
Reportersalbert 
Assigned Tosalbert 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0001070: otb::DEMHandler not updated properly when resetting DEM-directory and/or Geoid-file.
DescriptionWhen the user first enables then sets DEM-directory and/or Geoid-file, the otb::DEMHandler is initialized using ::OpenDEMDirectory() and/or ::OpenGeoidFile() which sets up the ossimElevationManager and/or ossimGeoidManager.

When the user then disables or clears the DEM-directory and/or Geoid-file, the DEMHandler is not updated in I18nCoreApplication::ElevationSetup() because there is no interface on otb::DEMHandler to clear the DEM-directory and/or Geoid-file.
TagsNo tags attached.
Attached Files

-Relationships
related to 0001071closedgpasero OTB-lib Add otb::DEMHandler ::ClearDEMDirectory() and ::ClearGeoidFile() interface. 
+Relationships

-Notes

~0003001

salbert (developer)

Fixed in 'DEMHandler_clear' branch.
+Notes

-Issue History
Date Modified Username Field Change
2015-09-15 12:46 salbert New Issue
2015-09-15 12:52 salbert Relationship added related to 0001071
2015-09-17 12:53 salbert Assigned To => salbert
2015-09-17 12:53 salbert Status new => assigned
2015-09-17 13:19 salbert Note Added: 0003001
2015-09-17 13:19 salbert Status assigned => closed
2015-09-17 13:19 salbert Resolution open => fixed
2015-09-17 15:17 salbert Status closed => feedback
2015-09-17 15:17 salbert Resolution fixed => reopened
2015-09-17 15:17 salbert Status feedback => resolved
2015-09-17 15:17 salbert Resolution reopened => fixed
2015-11-10 10:09 cpalmann Status resolved => closed
+Issue History